
BLOOMING MINDS CENTRAL SCHOOL & JR COLLEGE (+1 & +2) 

Class X-A Holidays Work 

TELUGU: 

 వ్యా కరణాంశాలు, అలాంకారాలు, వ్యటి సూత్రాలు, లక్షణలు, 2 ఉదాహరణలు,  

 సాంధులు:- పాంప్వా దేశ సాంధి, పడా్వ ది సాంధి, రుగాగామ సాంధి, గసడవ్యదేశ 

సాంధి (P.g No: 65,82,83,87,88) 

 2. మన ఇతిహాసాం – రామాయణాం: రామాయణాం ఎాందుకు చదవ్యలి? (P.g.No: 

132 TB) 

HINDI: 

 लड़का लड़की एक समान एक अनुचे्छद लेखन ललखखए  

 पत्र लेखन आपके के्षत्र में बाजारोों में प्रलिबोंलिि होने के बावजूद “प्लाखिक थैललयाों” का उपयोग िड़ले से हो रहा 

है इस पर “नगर लनगम अलिकारी” पर पत्र ललखखए  

 “सोलर पोंखा बनाने वाली सोंस्था” सूयय शखि के प्रचार एक “एक लवज्ञापन” ललखखए 

ENGLISH: 

 Find out at least 6-8 persons who fought for Indian’s freedom and compare and 

contrast with Nelson Mandela who fought for South Africa’s freedom. 

MATHEMATICS: 

 Read and write all chapter formulas(one-twelve) 

PHYSICS: 

 Applications, uses of a Concave and Convex mirror 

CHEMISTRY: 

 Write activities1.3,1.4,1.5,1.6,1.7 and 1.8 

BOTANY: 

 Collect the information about our Environment  

ZOOLOGY: 

 Prepare a chart of Endocrine system. 

SOCIAL SCIENCE: 

 Explain land degradation and conservation measures. 

 Explain soil erosion and soil conservation 

 How to create more employment? 

INFORMATION TECHNOLOGY: 

 Complete the Record work and Project work. 

 

BLOOMING MINDS CENTRAL SCHOOL & JR COLLEGE (+1 & +2) 



Class X-B Holidays Work 

TELUGU: 

 వ్యా కరణాంశాలు, అలాంకారాలు, వ్యటి సూత్రాలు, లక్షణలు, 2 ఉదాహరణలు,  

 సాంధులు:- పాంప్వా దేశ సాంధి, పడా్వ ది సాంధి, రుగాగామ సాంధి, గసడవ్యదేశ 

సాంధి (P.g No: 65,82,83,87,88) 

 2. మన ఇతిహాసాం – రామాయణాం: రామాయణాం ఎాందుకు చదవ్యలి? (P.g.No: 

132 TB) 

HINDI: 

 लड़का लड़की एक समान एक अनुचे्छद लेखन ललखखए  

 पत्र लेखन आपके के्षत्र में बाजारोों में प्रलिबोंलिि होने के बावजूद “प्लाखिक थैललयाों” का उपयोग िड़ले से हो रहा 

है इस पर “नगर लनगम अलिकारी” पर पत्र ललखखए  

 “सोलर पोंखा बनाने वाली सोंस्था” सूयय शखि के प्रचार एक “एक लवज्ञापन” ललखखए 

ENGLISH: 

 Write the summary of lesson: His first flight, Black aeroplane 

 Write an analytical paragraph for Q.7 in pg-53 volume-1 

 Write a letter to the director for Q.No-4 in page -51 volume-1 

MATHEMATICS: 

 Read and write all chapter formulas(one-twelve) 

PHYSICS: 

 Applications, uses of a Concave and Convex mirror 

CHEMISTRY: 

 Write activities1.3,1.4,1.5,1.6,1.7 and 1.8 

BOTANY: 

 Collect the information about our Environment  

ZOOLOGY: 

 Prepare a chart of Endocrine system. 

SOCIAL SCIENCE: 

 Explain land degradation and conservation measures. 

 Explain soil erosion and soil conservation 

 How to create more employment? 

INFORMATION TECHNOLOGY: 

 Complete the Record work and Project work. 

BLOOMING MINDS CENTRAL SCHOOL & JR COLLEGE (+1 & +2) 

Class X-C Holidays Work 



TELUGU: 

 వ్యా కరణాంశాలు, అలాంకారాలు, వ్యటి సూత్రాలు, లక్షణలు, 2 ఉదాహరణలు,  

 సాంధులు:- పాంప్వా దేశ సాంధి, పడా్వ ది సాంధి, రుగాగామ సాంధి, గసడవ్యదేశ 

సాంధి (P.g No: 65,82,83,87,88) 

 2. మన ఇతిహాసాం – రామాయణాం: రామాయణాం ఎాందుకు చదవ్యలి? (P.g.No: 

132 TB) 

HINDI: 

 लड़का लड़की एक समान एक अनुचे्छद लेखन ललखखए  

 पत्र लेखन आपके के्षत्र में बाजारोों में प्रलिबोंलिि होने के बावजूद “प्लाखिक थैललयाों” का उपयोग िड़ले से हो रहा 

है इस पर “नगर लनगम अलिकारी” पर पत्र ललखखए  

 “सोलर पोंखा बनाने वाली सोंस्था” सूयय शखि के प्रचार एक “एक लवज्ञापन” ललखखए 

ENGLISH: 

 Find out at least 6-8 persons who fought for Indian’s freedom and compare and 

contrast with Nelson Mandela who fought for South Africa’s freedom. 

MATHEMATICS: 

 Read and write all chapter formulae. Read -IIT 

PHYSICS: 

 Concave mirror-focal length by distant object method. 

 Convex Mirror, focal length by distant object method. 

CHEMISTRY: 

 Write all chemical reactions from- Chemical reactions and equations, Acids, Bases 

and salts. 

BOTANY: 

 Collect the information about our Environment topic in A4 sheets 

ZOOLOGY: 

 Prepare a chart of Endocrine system. 

SOCIAL SCIENCE: 

 Explain land degradation and conservation measures. 

 Explain soil erosion and soil conservation 

 How to create more employment? 

INFORMATION TECHNOLOGY: 

 Complete the Record work and Project work. 

1. Explain the styles given in the styles and formatting window for writer and paste the screen shot of 

the window 



Styles are available through a floating or dockable window called Styles and Formatting. This window is at the center 

of styles management. Do not worry if, at first, some contents of this section seem obscure while progressing through 

this or the next chapter. This guide describes how to use all these functions. 

 

Styles and Formatting window buttons. 

To open the Styles and Formatting window, do any one of the following: 

 Click on the  icon located at the left-hand end of the formatting toolbar. 

 Select Format > Styles and Formatting. 

 Press F11. 

 

You can move the Styles and Formatting window to a convenient position on the screen or dock it to an edge. 

 

Style selection basics 

The first five icons at the top of the Styles and Formatting window select the category of styles to work on. Click on 

one of these icons to display a list of styles in that category, such as paragraph or character styles, in the main 

window. 

To apply a character style to existing text, select the text and then double-click on the name of the style in 

the Character Styles list. To apply any other style, put the cursor in the paragraph, frame, or page you want to modify 

and double-click on the name of the style in the corresponding section. You can select more than one paragraph or 

frame and apply the same style to all of them at the same time. 

Using Fill Format mode 

The sixth icon at the top of the Styles and Formatting window activates the Fill Format mode. Use Fill Format to apply 

a style to many different areas quickly without having to go back to the Styles and Formatting window and double-click 

every time. This method is useful for formatting many scattered paragraphs, words, or other items with the same style, 

and it may be easier to use than making multiple selections first and then applying a style to all of them. 

1. Open the Styles and Formatting window and select a style. 

2. Click the Fill Format Mode icon . 

3. To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or frame and click. To 

apply a character style, hold down the mouse button while selecting the characters. Clicking on a word 

applies the character style for that word. 

https://wiki.openoffice.org/wiki/File:StylesFormatWindow3.png
https://wiki.openoffice.org/wiki/File:Styles3Icon.png
https://wiki.openoffice.org/wiki/File:Tip.png
https://wiki.openoffice.org/wiki/File:FillFormatIcon.png


4. Repeat step 3 until you made all the changes for that style. 

5. To quit the Fill Format mode, click the icon again or press the Esc key.  
Note: When this mode is active, a right-click anywhere in the document undoes the last Fill Format action. Be careful not to 

accidentally right-click and mistakenly undo actions you want to keep. 

New Style from Selection, Update Style, and Load Styles functions 

The last button in the toolbar of the Styles and Formatting window is a multipurpose button that gives access to three 

different functions: New Style from Selection, Update Style, and Load Styles. 

Using New Style from Selection 

Use the first function of the multipurpose button to create a new style from the formatting of an object in the current 

document. For instance, you can change the formatting of a paragraph or frame until it appears as you like, and then 

you can turn that object’s formatting into a new style. This procedure can save time because you do not have 

remember all the formatting settings you want, as is necessary when creating a new style with the Style dialog box. 

Besides, unlike when setting the formatting parameters in dialog box pages as you will learn to do later, you can 

immediately see how the objects will look like when formatted with the style you are creating. 

Follow these steps to create a new style from a selection: 

1. Change the formatting of the object (paragraph, frame, etc.) to your liking. 

2. From the icons at the top of the window, choose the type of style to create (paragraph, character, and so on). 

3. In the document, select the item to save as a style. 

4. Go back to the Styles and Formatting window and click the New Style from Selection icon. 

In the Create Style dialog box, enter a name for the new style. The list shows the names of existing custom styles of 

the selected type, if any. Click OK to save the new style. 

 

Naming a new style created from a selection. 

Update Style (from a selection) 

Let’s use paragraph styles as an example. 

1. Create a new paragraph (or modify an existing paragraph) and edit all the properties you want to go into the 

style (such as indentation, font properties, alignment, among others). 

Note:  Make sure that there are unique properties in this paragraph. For example, if there are two different font sizes in the 

paragraph selected to update the style, that particular property will not be updated. 

1. Select the paragraph by clicking anywhere in the paragraph. 

2. In the Styles and Formatting window, select the style you want to update (single-click, not double-click) and 

then click on the New Style from Selection icon and select Update Style. 

https://wiki.openoffice.org/wiki/File:CreateStyle3.png


 

Updating a style from a selection. 

The procedure to update another type of style (character, page, or frame styles) is the same. Just select the item in 

question, select the style you want to update, and choose Update Style. 

Load Styles (from a template or document) 

The last option in the New Style from Selection icon is used to copy styles into the current document by loading 

them from a template or another document. This method copies all styles, or groups of styles, at one time. 

1. Open the document to copy styles into. 

2. In the Styles and Formatting window, click on the New Style from Selection icon and then on Load Styles. 

3. In the Load Styles dialog box, find and select the template to copy styles from. Click on the From File button if 

the styles you want are contained in a text document rather than a template. In this case, a standard file 

selection dialog box opens up, allowing you to select the desired document. 

4. Select the check boxes for the types of styles to be copied. If you select Overwrite, the styles being copied 

will replace any styles of the same names in the target document. 

5. Click OK to copy the styles. 

 

Loading styles from a template. 

Using the visible styles filters 

At the bottom of the Styles and Formatting window, use the drop-down menu to select a filtering criterion for the 

contents of the main body of the window. Normally, you will find that only a handful of styles are needed in any given 

document, and it makes sense to have only these styles shown. 

So, at the beginning of the writing process, you may want to have access to all the available styles (by selecting All 

Styles). However, as the document develops, it is useful to reduce the size of the list displayed to only the styles 

already in use (by selecting Applied Styles). If you work on a document where you want to apply special-purpose 

styles only (such as those styles used in writing this user guide), select instead Custom Styles. The Hierarchical 

Styles view is most useful when modifying styles as it reveals which styles are linked together. This topic is discussed 

in more detail in Chapter 7 (Working with Styles). 

https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide/Working_with_Styles
https://wiki.openoffice.org/wiki/File:UpdateStyle.png
https://wiki.openoffice.org/wiki/File:LoadStyles3.png


If you select the Paragraph Styles view in the Styles and Formatting window, the drop-down menu contains many 

more filtering options so you can view, for example, only Text Styles, Special Styles, and so on. 

Drag-and-drop a selection to create a style 

Another little known property of the Styles and Formatting window is the capability of creating a new style with a 

simple drag-and-drop of a text selection into the Styles and Formatting window. 

1. Open the Styles and Formatting window. 

2. Select the style category you are going to create (for example a character style) using one of the five icons in 

the top left part of the window. 

3. Select the object you want to base the style on and drag it to the Styles and Formatting window. The cursor 

changes its shape indicating whether the operation is possible or not. 

4. In the Create Style dialog box, enter a name for the new style. The list shows the names of existing custom 

styles of the selected type, if any. Click OK to save the new style. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Q2. Write the steps to create new style in Open Office Writer? 



Creating new (custom) styles 

 

In addition to using the predefined styles provided by OOo, you can add new custom (user-defined) styles. OOo 

provides three ways to add styles. 

 Create a new style using the Style dialog box. 

 Create a new style from a selection. 

 Drag and drop a selection to create a new style. 

Creating a new style using the Style dialog box 

Open the Styles and Formatting window. Right-click on a style and select New. The style that you choose will be 

the basis for this new style. If you do not want too many of the options preset for you, choose the Default style. 

The dialog box displayed depends on the type of style selected. The figure below shows an example of a Style 

dialog box for a new paragraph style. The dialog boxes and choices for defining new styles are the same as for 

modifying existing styles. 

 

An exception to the above rule is conditional styles, which have a different dialog box. See Working with conditional 

paragraph styles for more information. 

 

Linking styles 

You can link a new style to an existing style. For example, suppose that the style mystyle specifies a font size of 

12. Then you create another style (mystyle2) linked to mystyle and specifies underlined text. If you 

modify mystyle to font size 20, mystyle2 inherits the new font size but still underlines the text. 

 

Linking a new paragraph style to an existing style. 

 

If styles are linked, changing the base style changes all the linked styles. Sometimes this is exactly what you want; 

other times it is not. It pays to plan ahead. Many predefined styles are already linked to other styles. 

 

Creating a new style from a selection 

You can create a new style from the formatting of an object in the current document. For instance, you can 

change the formatting of a paragraph or frame until it appears as you like, and then you can turn that object's 

formatting into a new style. This procedure can save time, because you do not have to create a new style as 

described above and remember all of the formatting settings. 

https://wiki.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Creating_new_(custom)_styles#Creating_a_new_style_using_the_Style_dialog_box
https://wiki.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Creating_new_(custom)_styles#Creating_a_new_style_from_a_selection
https://wiki.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Creating_new_(custom)_styles#Dragging_and_dropping_a_selection_to_create_a_style
https://wiki.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Working_with_conditional_paragraph_styles
https://wiki.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Working_with_conditional_paragraph_styles
https://wiki.openoffice.org/wiki/File:Tip.png
https://wiki.openoffice.org/wiki/File:LinkStyles.png
https://wiki.openoffice.org/wiki/File:Tip.png


1. Change the formatting of the object (paragraph, frame, etc) to your liking. 

2. Open the Styles and Formatting window. From the icons at the top of the window, choose the type of 

style to create (paragraph, character, and so on). 

3. In the document, select the item to save as a style. 

4. In the Styles and Formatting window, click the New Style from Selection icon. 

5. In the Create Style dialog box, type a name for the new style. The list shows the names of existing 

custom styles of the selected type, if any. Click OK to save the new style. 

Dragging and dropping a selection to create a style 

You can drag and drop a text selection into the Styles and Formatting window to create a new style. 

1. Open the Styles and Formatting window. 

2. Select some text and drag it to the Styles and Formatting window. 

3. In the Create Style dialog box, type a name for the new style. The list shows the names of existing 

custom styles of the selected type, if any. Click OK to save the new style. 

4. If the Paragraph Styles list is showing in the Styles and Formatting window, a new paragraph style will be 

added to the list. If Character Styles are active, the character style will be added to the list. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Write the steps to insert an image in a document. Explain three methods 
along with screen shots? 



Inserting an image file 

When the image is in a file stored on the computer, you can insert it into an OOo document using either of the 

following methods. 

Drag and drop 

1. Open a file browser window and locate the image you want to insert. 

2. Drag the image into the Writer document and drop it where you want it to appear. A faint vertical line marks 

where the image will be dropped. 

This method embeds (saves a copy of) the image file in the Writer document. To link the file instead of embedding it, 

hold down the Control+Shift keys while dragging the image. 

Insert Picture dialog 

1. Click in the OOo document where you want the image to appear. 

2. Choose Insert > Picture > From File from the menu bar. 

3. On the Insert Picture dialog, navigate to the file to be inserted, select it, and click Open. 

 

Insert picture dialog 

At the bottom of the dialog are two options, Preview and Link. Select Preview to view a thumbnail of the selected 

image on the right, so you can verify that you have the correct file. See below for the use of Link. 

Linking an image file 

If the Link option in the Insert picture dialog is selected, OOo creates a link to the file containing the image, instead of 

saving a copy of the image in the document. The result is that the image is displayed in the document, but when the 

document is saved, it contains only a reference to the image file—not the image itself. The document and the image 

remain as two separate files, and they are merged together only when you open the document again. 

Linking an image has two advantages and one disadvantage: 

 Advantage – Linking can reduce the size of the document when it is saved, because the image file itself is not 

included. File size is usually not a problem on a modern computer with a reasonable amount of memory, unless 

the document includes many large graphics files; OOo can handle quite large files. 

https://wiki.openoffice.org/wiki/File:WG8-1.png


 Advantage – You can modify the image file separately without changing the document because the link to the file 

remains valid, and the modified image will appear when you next open the document. This can be a big 

advantage if you (or someone else, perhaps a graphic artist) is updating images. 

 Disadvantage – If you send the document to someone else, or move it to a different computer, you must also 

send the image files, or the receiver will not be able to see the linked images. You need to keep track of the 

location of the images and make sure the recipient knows where to put them on another machine, so the 

document can find them. For example, you might keep images in a subfolder named Images (under the folder 

containing the document); the recipient of the file needs to put the images in a subfolder with the same name 

(under the folder containing the document). 

  

Embedding linked images 

If you originally linked the images, you can easily embed one or more of them later if you wish. To do so: 

1. Open the document in OpenOffice.org and choose Edit > Links. 

2. The Edit Links dialog shows all the linked files. In the Source file list, select the files you want to change from 

linked to embedded. 

3. Click the Break Link button. 

4. Save the document. 

 

The Edit Links dialog 

 

 

 

 

 

 

 

 

 

https://wiki.openoffice.org/wiki/File:EditLinks3.png


Q4. Design a poster on “sale in Big bazar” by using image and drawing 

tools. 

If you want to design and print your own posters, Apache OpenOffice 4.1 has the tools you need. 

OpenOffice's Drawing option gives you the ability to add a background, import graphics and add text in 

whatever position or angle you wish. If you're using your own artwork in a poster, use high-resolution 

photos to ensure they stay crisp when you print them. 

Setting the Poster Size and Background 

Step 1 

Select "New" from the OpenOffice File menu and then "Drawing." 

Step 2 

Specify a page size if you want your poster to be a size other than the default letter size. Select "Page" from 

the Format menu and click a pre-defined size. Alternatively, specify your own page size by setting the 

width, height and orientation manually. You can also set the margins here. If you reduce the margins to zero, 

keep in mind that the edges may be cropped when printing, depending on the printer you use. 

Step 3 

Click the "Background" tab. Clicking the "Fill" menu, you can select from a variety of colors and gradients, 

bitmap images and textured hatchings. When you click one, a thumbnail preview displays. If you select a 

bitmap, you can turn off the "Tile" option; however, this will make the background blurry on most posters 

since the small image is expanded to fill the entire document. Click "OK" to save your selection and close 

the Page Setup window. 

Adding Graphics 

Step 1 

Select "Picture" from the Insert menu. Click "From File" and then select an image. Of course, if the picture 

is on your desktop, you can simply drag it onto the slide. 

Step 2 

Add shapes, such as an oval or rectangle, by selecting one from the menu in the right pane. Alternatively, 

select shapes from the toolbar at the bottom of the OpenOffice Window. Drag the cursor across the screen. 

You can change the fill color, line weight and transparency of a shape using the menu options on the right. 

Step 3 

Drag a shape or image onto the poster. When you insert a new object or click it, a border displays around the 

image with eight anchor points. Drag any anchor point to resize the object. Hold down the "Shift" key to 

retain the object's aspect ratio while resizing it. 

Step 4 

Click an image or shape, wait a moment and then click it a second time if you want to rotate it. The eight 

anchor points around the object turn red, indicating that you can now rotate it by dragging an anchor point. 

If you hold down the Shift key, you can restrict the rotation to 30-degree increments. 



Adding Text 

Step 1 

Click the T-shaped "Text" icon at the bottom of the OpenOffice window, or press "F2," and then drag the 

cursor over the slide to add a text box. Formatting options appear in the right pane. If your poster's design is 

particularly busy with shapes and images, enlarge the text size -- 48 points might be effective for a heading, 

for instance -- before typing, so you can easily spot the text on your poster. Although the maximum font size 

is 96 points, you can enter any size you wish by typing it in the font size "Text" field rather than selecting a 

size from the menu. 

Step 2 

Type a title for your poster in the text box. To edit the text, click and drag across the words to highlight 

them. To select the text box itself, click the words, then click the text box border. You can move, resize or 

rotate the text box just as you would with a shape or image. 

Step 3 

Add additional text boxes to include details for your poster as needed. Print your poster or export it to a PDF 

file for sharing digitally using the options from the File menu. 

 



 

 



 

1. Open the document that contains the cell ranges to be consolidated. 

2. Choose Data > Consolidate to open the Consolidate dialog. The figure shows this dialog after making the 

changes described below. 

 

Defining the data to be consolidated 

3. The Source data range list contains any existing named ranges (created using Data > Define Range), so 

you can quickly select one to consolidate with other areas. 

https://wiki.openoffice.org/wiki/File:CG3Ch7F1.png


If the source range is not named, click in the field to the right of the drop-down list and either type a reference 

for the first source data range or use the mouse to select the range on the sheet. (You may need to move the 

Consolidate dialog or click on the Shrink icon to reach the required cells.) 

4. Click Add. The selected range is added to the Consolidation ranges list. 

5. Select additional ranges and click Add after each selection. 

6. Specify where you want to display the result by selecting a target range from the Copy results to drop-down 

list. 

If the target range is not named, click in the field next to Copy results to and enter the reference of the target 

range or select the range using the mouse or position the cursor in the top left cell of the target range. Copy 

results to takes only the first cell of the target range instead of the entire range as is the case for Source data 

range. 

7. Select a function from the Function list. This specifies how the values of the consolidation ranges will be 

calculated. The default setting is Sum, which adds the corresponding cell values of the Source data range 

and gives the result in the target range. 

Most of the available functions are statistical (such as Average, Min, Max, Stdev), and the tool is most useful 

when you are working with the same data over and over. 

8. At this point you can click More in the Consolidate dialog to access the following additional settings: 

o Select Link to source data to insert the formulas that generate the results into the target range, rather 

than the actual results. If you link the data, any values modified in the source range are automatically 

updated in the target range. 

 

The corresponding cell references in the target range are inserted in consecutive rows, which are 

automatically ordered and then hidden from view. Only the final result, based on the selected function, is 

displayed. 

o Under Consolidate by, select either Row labels or Column labels if the cells of the source data range 

are not to be consolidated corresponding to the identical position of the cell in the range, but instead 

according to a matching row label or column label. To consolidate by row labels or column labels, the 

label must be contained in the selected source ranges. The text in the labels must be identical, so that 

rows or columns can be accurately matched. If the row or column label does not match any that exist in 

the target range, it is added to the target range as a new row or column. 

9. Click OK to consolidate the ranges. 

10. If you are continually working with the same range, then you probably want to use Data > Create Range to 

give it a name. 

The consolidation ranges and target range are saved as part of the document. If you later open a document in which 

consolidation has been defined, this data is still available. 
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Q5. Write the steps to create scenario in open office calc along with the 

screenshot of the window? 

Scenarios are a tool to test “what-if” questions. Each scenario is named, and can be edited and formatted separately. 

When you print the spreadsheet, only the contents of the currently active scenario is printed. 

A scenario is essentially a saved set of cell values for your calculations. You can easily switch between these sets 

using the Navigator or a drop-down list which can be shown beside the changing cells. For example, if you wanted to 

calculate the effect of different interest rates on an investment, you could add a scenario for each interest rate, and 

quickly view the results. Formulas that rely on the values changed by your scenario are updated when the scenario is 

opened. If all your sources of income used scenarios, you could efficiently build a complex model of your possible 

income. 

Creating scenarios 

Tools > Scenarios opens a dialog with options for creating a scenario. To create a new scenario: 

1. Select the cells that contain the values that will change between scenarios. To select multiple ranges, hold 

down the Ctrl key as you click. You must select at least two cells. 

2. Choose Tools > Scenarios. 

3. On the Create Scenario dialog, enter a name for the new scenario. It’s best to use a name that clearly 

identifies the scenario, not the default name as shown in the illustration. This name is displayed in the 

Navigator and on the title bar of the scenario on the sheet itself. 

 

Creating a scenario 

4. Optionally add some information to the Comment box. The example shows the default comment. This 

information is displayed in the Navigator when you click the Scenarios icon and select the desired scenario. 

5. Optionally select or deselect the options in the Settings section. See below for more information about these 

options. 

6. Click OK to close the dialog. The new scenario is automatically activated. 

You can create several scenarios for any given range of cells. 

Settings 

https://wiki.openoffice.org/wiki/File:CG3Ch7F4.png


The lower portion of the Create Scenario dialog contains several options. In most cases the default settings (shown 

selected in the example) are likely to be suitable in most situations. 

Display border 

Places a border around the range of cells that your scenario alters. To choose the color of the border, use the field to 

the right of this option. The border has a title bar displaying the name of the active scenario. Click the arrow button on 

the right of the scenario name to open a drop-down list of all the scenarios that have been defined for the cells within 

the border. You can choose any of the scenarios from this list at any time. 

Copy back 

Copies any changes you make to the values of scenario cells back into the active scenario. If you do not select this 

option, the saved scenario values are never changed when you make changes. The actual behavior of the Copy 

back setting depends on the cell protection, the sheet protection, and the Prevent changes settings. 

 
 

Copy entire sheet 

Adds to your document a sheet that permanently displays the new scenario in full. This is in addition to creating the 

scenario and making it selectable on the original sheet as normal. 

 

Prevent changes 

Prevents changes to a Copy back-enabled scenario when the sheet is protected but the cells are not. Also prevents 

changes to the settings described in this section while the sheet is protected. A fuller explanation of the effect this 

option has in different situation is given below. 

 

Changing scenarios 

Scenarios have two aspects which can be altered independently: 

 Scenario properties (the settings described above) 

 Scenario cell values (the entries within the scenario border) 

The extent to which either of these aspects can be changed is dependent upon both the existing properties of the 

scenario and the current protection state of the sheet and cells. 

 

Changing scenario properties 

If the sheet is protected (Tools > Protect Document > Sheet), and Prevent changes is selected then scenario 

properties cannot be changed. 

If the sheet is protected, and Prevent changes is not selected, then all scenario properties can be changed 

except Prevent changes and Copy entire sheet, which are disabled. 

If the sheet is not protected, then Prevent changes does not have any effect, and all scenario properties can be 

changed. 

Changing scenario cell values 

The table below summarizes the interaction of various settings in preventing or allowing changes in scenario cell 

values. 

Settings Change allowed 

Sheet protection ON Scenario cell values cannot be changed. 



Scenario cell protection OFF 

Prevent changes ON 

Copy back ON 

Sheet protection ON 

Scenario cell protection OFF 

Prevent changes OFF 

Copy back ON 

Scenario cell values can be changed, and the scenario is updated. 

Sheet protection ON 

Scenario cell protection OFF 

Prevent changes ON or OFF 

Copy back OFF 

Scenario cell values can be changed, but the scenario is not updated due to the 

Copy back setting. 

Sheet protection ON 

Scenario cell protection ON 

Prevent changes ANY 

SETTING 

Copy back ANY SETTING 

Scenario cell values cannot be changed. 

Sheet protection OFF 

Scenario cell protection ANY 

SETTING 

Prevent changes ANY 

SETTING 

Copy back ANY SETTING 

Scenario cell values can be changed and the scenario is updated or not, depending 

on the Copy back setting. 

Working with scenarios using the Navigator 

After scenarios are added to a spreadsheet, you can jump to a particular scenario by selecting it from the list in the 

Navigator. 

To find a scenario, click the Scenarios icon in the Navigator. The defined scenarios are listed, along with the 

comments that were entered when the scenarios were created. 

 

Scenarios in the Navigator 

To apply a scenario to the current sheet, double-click the scenario name in the Navigator. 

To delete a scenario, right-click the name in the Navigator and choose Delete. 

https://wiki.openoffice.org/wiki/File:CG3Ch7F5.png


To edit a scenario, including its name and comments, right-click the name in the Navigator and choose Properties. 

The Edit Properties dialog is the same as the Create Scenario dialog. 

To learn which values in the scenario affect other values, choose Tools > Detective > Trace Dependents. Arrows 

point to the cells that are directly dependent on the current cell. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Q7. Write the steps to record Macro in open office Calc 

Using the macro recorder 

 

The following steps create a macro that performs paste special with multiply. 

1. Open a new spreadsheet. 

2. Enter numbers into a sheet. 

 

Enter numbers. 

3. Select cell A3, which contains the number 3, and copy the value to the clipboard. 

4. Select the range A1:C3. 

5. Use Tools > Macros > Record Macro to start the macro recorder. The Record Macro dialog is displayed 

with a stop recording button. 

 

Stop recording button. 

6. Use Edit > Paste Special to open the Paste Special dialog. 

 

Paste Special dialog. 
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7. Set the operation to Multiply and click OK. The cells are now multiplied by 3. 

 

Cells multiplied by 3. 

8. Click Stop Recording to stop the macro recorder. The OpenOffice.org Basic Macros dialog opens. 

9. Select the current document. For this example, the current Calc document is Untitled 1. Existing 

documents show a library named Standard. This library is not created until the document is saved, or the 

library is needed, so at this point your new document does not contain a library. You can create a new 

library to contain the macro, but this is not necessary. 

 

Select the Standard library if it exists. 

10. Click New Module. If no libraries exist, then the Standard library is automatically created and used. In 

the New Module dialog, type a name for the new module or leave the name as Module1. 

 

11. Click OK to create a module named Module1. Select the newly created Module1, enter the macro 

name PasteMultiply and click Save. 
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Select the module and name the macro. 

12. The created macro is saved in Module1 of the Standard library in the Untitled 1 document. Listing 1 

shows the contents of the macro.. 
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Q8. Write the steps to create table with minimum five fields on 

an entry STUDENT in design view 
 

Here's how to create a table in Design View. 

1.  

Click the Table Design Button 

Click Table Design on the Ribbon (from the Create tab). 

2.  

https://www.quackit.com/pix/microsoft_access/microsoft_access_2016/howto/how_to_create_a_table_in_design_view_in_access_2016_1.png
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The Blank Table 

A blank table will appear in Design View. 

You can see that field names are to be entered on top of each other down the left column, and their 

corresponding data types will be listed in the next column. 

One of the big differences between Design View and Datasheet View is how they display the fields. 

Design View displays them as rows (down the left), whereas, Datasheet View displays them as 

columns (along the top). 

Regardless, this doesn't change the design of the table. It's still the same table whether it was 

designed in Datasheet View or Design View. 

3.  

Enter the Fields 

Enter a name for each field down the left column. 

Select each field's data type from the next column. 

You can also create a lookup table if required, by selecting Lookup Wizard... from the data type 

list. 

https://www.quackit.com/microsoft_access/microsoft_access_2016/tutorial/create_a_lookup_table_in_microsoft_access.cfm
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4.  

Enter the Field Properties 

You can also change each field's properties in the bottom pane. 

To do this, you need to click on the field first. Clicking a field updates the bottom pane with the 

properties for that field. 

The properties displayed in the bottom pane are different, depending on the data type of the selected 

field. 

5. Set a Primary Key 

To set a field as a primary key, right click on the field and select Primary Key. 

Once the table has been configured, be sure to save it. In any case, you will be prompted to save it when you 

try to switch to Datasheet View or close the table. 

You can switch between Design View and Datasheet View at any time by using the little Datasheet 

View/Design View icons at the botton right of the screen, or the View icon in the left part of the Ribbon 

(from the Design tab). 

Design View vs Datasheet View 

You can create a table in either Datasheet View or Design View. Generally, you can do most things in both 

views. However, there are some things you can do in Design View that you can't in Datasheet View. 
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Q9. Write the command for the following table : student 
 

Roll no   Class   Name   Phone_no 

1   XII   Sumit   1234565 

2   X   Amit   3564583 

3   X   Anuj   1236589 

4   XI   Mini   5869542 

 

Student Table : IT 402 

1. Display all the records of tables student. 
2. Insert one record of your choice. 
3. Display record of student whose roll number is 3. 
4. Display record of students who are in class ‘X’. 
5. Display the record of ‘Anuj’ 

Answer.  

1.Select * from student; 

2. Insert into student values(5, 'XI' , 'Suman' , 6953245) 

3. Select * from student where Rollno = 3; 

4. Select * from student where class = 'X' 

5. Select * from student where name = 'Anuj'; 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Q10. Write the steps to create Report in Open Office base. 

Reports provide information found in the database in a useful way. In this they are similar to queries. Reports are 

generated from the database's tables or queries. They can contain all of the fields of the table or query or just a 

selected group of fields. Reports can be static or dynamic. Static reports contain the data in the selected fields at the 

time the report was created. Dynamic reports can be updated to show the latest data. 

  

For example, a report on vacation expenses divided into categories should probably be a static report because it is 

based upon specific data that does not change. However, a report on the fuel data should probably be a dynamic 

report, because this report depends upon data that does change. 

  

An example of this caution is creating a report on vacation expenses. Fuel costs are one part of that report as are 

meal costs. These values are contained in fields of two different tables: Vacations and Fuel. So this report requires 

creating a query. 

Creating a static report 

We will create a report on vacation expenses. Certain questions need to be asked before creating the report. 

 What information do we want in the report? 

 How do we want the information arraigned? 

 What fields are required to provide this information? 

 Will a query have to be created because these fields are in different tables? 

 Are there any calculations required in the data before being added to the report? 

The expenses for our vacation are motel, tolls, miscellaneous, breakfast, lunch, supper, snacks, and fuel. One 

possible report would simply list the totals of each of these expense groups. Another possible report would list the 

expense totals for each day of the vacation. A third possible report would list the totals for each expense group for 

each type of payment. (This would let us know where the money came from to pay the expenses.) At the present time, 

using the data from the queries in a spreadsheet is the best way to handle reports like this. In the near future, the 

report feature will include these abilities. 

For our purposes, we will create two reports. The first one will list the expenses each day other than fuel. The second 

report will list the fuel costs each day. 

The fields we will need for the first report from the Vacations table are: Date, Motel, Toll, Breakfast, Lunch, Supper, 

SnackCost, and Miscellaneous. This report will not require an additional query. 

The second report involves the Fuel table. Since fuel was purchased and entered into this table at times other than 

during the vacation, a query needs to be created that contains only the fuel purchased during the vacation. 

Vacations table report 

1. Create a new report. 

a. Click the Reports icon in the Database list in the Automobile - OpenOffice.org window. 

b. In the Tasks list, click Use Wizard to Create Report. The Report Wizard window opens. 

2. Select the fields. 

a. Select Table: Vacations in the Tables or Queries dropdown list. 



b. Use the > to move these fields from the Available fields list to the Fields in report list: Date, Motel, 

Tolls, Miscellaneous, Breakfast, Lunch, Supper, and SnackCost. Click Next. 

 

Adding fields to a report. 

3. Label the fields: answering the question How do you want to label the fields. 

Shorten Miscellaneous to Misc. Click Next. 

4. Since we are grouping by the date, use the > button to move the Date field to the Grouping list. Click Next. 

 

Grouping list 

5. Sort options. 

We do not want to do any additional sorting. Click Next. 

6. Choose layout. 

We will be using the default settings for the layout. Click Next. 

 

If you feel adventurous, try selecting some of the other layout choices. After selecting a choice, drag and 

drop the Report Wizard window so that you can see what you have selected. (Move the cursor over the 

Heading of this window, and then drag and drop.) 

7. Create report. 

o Label the report: Vacation Expenses. 

o Select Static report. 

8. Click Finished. 

Top of page 

Vacation fuel report 
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1. Create a query containing only fuel bought on the days of the vacation. 

a. Open a query in Design View. 

b. Follow the steps for adding tables in Step 2: Add tables of Using the Design View to create a query. 

Add the Fuel table. 

c. Double-click these fields in the Fuel table listing: Date and FuelCost to enter them in the table at the 

bottom of the query. 

d. In the Criterion cell of the Date field, type the following: 

BETWEEN #5/25/2007# AND #5/26/2007# 

 

Setting the criterion for a query. 

e. Save, name, and close the query. (Suggestion: Vacation Fuel Purchases.) 

 

When using dates in a query, enter them in numerical form MM/DDYYYY or DD/MM/YYYY depending upon your 

language's default setting for dates (my default setting is MM/DD/YYYY). 

All dates must have a # before and after it. Hence, May 25, 2007 is written #05/25/2007# or 

#25/5/2007depending upon your language's default setting. 

 

2. Open a new report. 

a. Right-click the Vacation Fuel Purchases query. 

b. Select Report Wizard from the context menu. 

 

When a new report is opened in this way, the query used to open it is automatically selected in the Tables or 

Queries dropdown list. 

3. Create the report. 

Use >> to move both fields from the Available Fields to the Fields in Report list. Click Next. 

4. Label fields. 

Add a space to FuelCost to make it Fuel Cost (two words). Click Next. 

5. Group fields. 

a. Click Date to highlight it. 

b. Use > to move the Date field to the Groupings list. Click Next. 

6. Choose layout. 

We will be making no changes in the layout. Click Next. 

7. Create report (final settings). 

a. Use the suggested name, which is the same as the query. 

b. Select Static report. Click Finish. 

https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Getting_Started/Creating_queries_and_reports#Step_2:_Add_tables.
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